为Maven项目指定JDK版本

当使用 Eclipse 或者 IntelliJ IDEA 导入(import) maven项目时,如果项目源码中使用了 Java8 的语法,很可能会在源码文件中显示错误。解决这个问题很简单,只需要在 pom.xml 文件中指明使用的 Java 版本即可。

将这段代码加入 pom.xml 文件

1
2
3
4
5
6
7
8
9
10
11
12
13
14

<build>
<plugins>
<plugin>
<groupId>org.apache.maven.plugins</groupId>
<artifactId>maven-compiler-plugin</artifactId>
<version>3.6.1</version>
<configuration>
<source>1.8</source>
<target>1.8</target>
</configuration>
</plugin>
</plugins>
</build>

根据你具体项目的需要指定 source 和 target 所对应的版本。

本文标题:为Maven项目指定JDK版本

文章作者:梅老师

发布时间:2019年07月08日 - 21:07

最后更新:2020年09月16日 - 08:09

原始链接:https://www.mls-tech.info/java/java-maven-sdk8/

许可协议: 署名-非商业性使用-禁止演绎 4.0 国际 转载请保留原文链接及作者。